Zotonic
Zotonic
zotonic@conference.zotonic.com
Wednesday, 25 April 2012< ^ >
arjan has set the subject to: Zotonic - the Erlang CMS
Room Configuration

GMT+2
[00:25:18] simon.smithies joins the room
[02:29:55] simon.smithies leaves the room
[07:24:25] maas.maarten.zeeman joins the room
[07:33:17] maas.maarten.zeeman leaves the room
[07:35:54] maas.maarten.zeeman joins the room
[08:20:38] arjan joins the room
[09:10:02] fl joins the room
[11:30:11] arjan leaves the room
[11:33:12] arjan joins the room
[11:35:16] arjan leaves the room
[11:37:19] arjan joins the room
[12:12:59] arjan leaves the room
[12:29:19] maas.maarten.zeeman leaves the room
[12:30:05] arjan joins the room
[12:31:14] maas.maarten.zeeman joins the room
[13:20:47] arjan leaves the room
[13:27:10] arjan joins the room
[13:40:03] <fl> After reading some code: z_site_sup:add_db_pool starts a pgsql_pool process per Host
[13:41:50] <fl> Apart from that, I also had a look at pgsql.erl and pgsql_connection.erl and both the database instance per site as the schema per site scenario should work. I'm going to retest the schema per site scenario.
[14:10:52] <arjan> makes sense, I would expected it to work that way
[14:10:58] <arjan> let us know how it goes :)
[14:29:04] arjan leaves the room
[15:55:31] <fl> I re-tested it and it fails... Creation of the datamodel for site1 seems to succeed but for site2 it fails:
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:16.896 [info] [site1] info @ z_datamodel:148 Creating new resource 'media_learning'
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:17.322 [info] DEBUG: z_install_data:35 {site2,"Install start."}
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:17.325 [info] DEBUG: z_install_data:48 "Inserting config keys"
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:17.333 [info] DEBUG: z_install_data:57 "Inserting modules"
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> Terminating due to shutdown
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:17.474 [error] CRASH REPORT Process <0.148.0> with 0 neighbours crashed with reason: {timeout,{gen_server,call,[<0.149.0>,{start_child,site2}]}}
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> 15:47:17.503 [error] Supervisor zotonic_sup had child z_sites_manager started with z_sites_manager:start_link() at undefined exit with reason {timeout,{gen_server,call,[<0.149.0>,{start_child,site2}]}} in context start_error
[15:55:58] <fl> (zotonic001@anaxagoras.local)1> {"init terminating in do_boot",{{badmatch,{error,{shutdown,{zotonic_app,start,[normal,[]]}}}},[{zotonic,start,1},{init,start_it,1},{init,start_em,1}]}}
[15:55:58] <fl> Crash dump was written to: erl_crash.dump
[15:56:00] <fl> init terminating in do_boot ()
[15:57:37] <fl> I tee-ed stdout and stderr to a file. If you want, I can send it over.
[17:00:58] arjan joins the room
[17:27:05] maas.maarten.zeeman leaves the room
[18:38:04] arjan leaves the room
[18:42:50] maas.maarten.zeeman joins the room
[23:29:13] <Marc Worrell> @fl which version of zotonic do you use?
[23:34:51] <Marc Worrell> You can send me the logfiles, I will have a look. ( marc@worrell.nl )
[23:35:05] <Marc Worrell> The system should never fail like this if a single site has problems.
Powered by ejabberd Powered by Erlang Valid XHTML 1.0 Transitional Valid CSS!