Zotonic
Zotonic
zotonic@conference.zotonic.com
Thursday, 26 January 2012< ^ >
arjan has set the subject to: Zotonic - the Erlang CMS
Room Configuration

GMT+1
[03:36:30] simon.smithies joins the room
[03:36:34] simon.smithies leaves the room
[03:37:21] simon.smithies joins the room
[07:55:45] maas.maarten.zeeman joins the room
[08:08:38] maas.maarten.zeeman leaves the room
[08:12:38] arjan joins the room
[08:45:04] arjan leaves the room
[09:11:52] arjan joins the room
[09:58:20] <simon.smithies> Hi Arjan
[09:58:20] vio42 leaves the room
[09:58:25] <simon.smithies> Are you there?
[10:02:01] <arjan> hi simon
[10:02:24] <simon.smithies> finally working on zotonic again after a long time off
[10:02:45] <simon.smithies> am getting an error when I try to start it on my debian vps
[10:02:55] <simon.smithies> which is only running erlang 13b04
[10:03:07] <arjan> that's a pretty old release..
[10:03:08] <simon.smithies> seems I need 14b04 now?
[10:03:30] <arjan> yes I don't think r13 is supported from 0.8 up
[10:03:39] <simon.smithies> ok
[10:03:58] <simon.smithies> time to go work out whether to upgrade debian
[10:04:12] <simon.smithies> or build a later erlang fro source
[10:04:18] <simon.smithies> *from
[10:06:29] <arjan> yes one of those..
[10:06:40] <simon.smithies> :)
[10:06:53] <simon.smithies> congratualtions on the rapid progress you guys are making with zotonic
[10:07:32] <arjan> thank you :)
[10:08:16] <arjan> hmm I see that I use 13b03 on one server of mine
[10:08:21] <arjan> it runs on master
[10:08:29] <arjan> what kind of error are you getting?
[10:09:29] <simon.smithies> Erlang R13B04 (erts-5.7.5) [source] [smp:4:4] [rq:4] [async-threads:0] [hipe] [kernel-poll:true]
{"init terminating in do_boot",{undef,[{zotonic,start,[]},{init,start_it,1},{init,start_em,1}]}}
[10:09:33] <arjan> but anyway upgrading is always betetr, I know for sure that some modules do not work
[10:09:39] <arjan> eh did you do a make?
[10:09:56] <simon.smithies> actually I did ... hang on
[10:10:35] <simon.smithies> Directory 'deps/gen_smtp' exist, but is neither empty nor a git repository
[10:10:43] <simon.smithies> showing my ignorance here again
[10:10:49] <simon.smithies> has there been a git change?
[10:11:17] <simon.smithies> this is a make on master
[10:11:59] <simon.smithies> so a few errors, starting with the above, then:
[10:12:01] <simon.smithies> Recompile: src/zotonic_sup
include/zotonic.hrl:26: can't find include lib "deps/webzmachine/include/wm_reqdata.hrl"
make: *** [erl] Error 1
[10:13:58] <arjan> mm that means the submodules are not initialized
[10:14:05] <arjan> can you try: git submodule update --init
[10:14:10] <arjan> and then make again
[10:14:29] <arjan> same error?
[10:14:34] <simon.smithies> yes
[10:14:40] <arjan> ok then it's my fault
[10:14:52] <arjan> I made gen_smtp into a subrepo yesterday but apparently I did something wrong
[10:14:53] <arjan> hold on :)
[10:15:01] <simon.smithies> wow
[10:15:14] <simon.smithies> am holding
[10:16:22] <arjan> can you try: rm -rf deps/gen_smtp deps/webzmachine
[10:16:24] <arjan> and then make again
[10:16:42] <arjan> (just tried a clean checkout, that works fine)
[10:17:16] <simon.smithies> that looks a bit better!
[10:18:13] <arjan> cool
[10:18:44] <simon.smithies> starting now
[10:18:52] <simon.smithies> should I be concerned about this ...
[10:18:54] <simon.smithies> ** Found 17 name clashes in code paths
[10:20:02] <arjan> not really
[10:20:08] <simon.smithies> is running now
[10:20:08] <arjan> probably the result of us moving stuff around
[10:20:25] <simon.smithies> quite a few changes since I last ran it
[10:20:30] <simon.smithies> looks good
[10:21:01] <simon.smithies> nice to see the update button back again
[10:22:28] <arjan> :)
[10:22:34] <arjan> yes we finally added git support
[10:22:51] <arjan> I made the status site a bit friendlier ;)
[10:23:25] <simon.smithies> a bit less intimidating than the old darth vadder look
[10:23:29] <arjan> indeed
[10:24:11] <simon.smithies> do you remember I was having problems getting the media size stuff to work on my vps?
[10:24:31] <simon.smithies> I never solved that ... I guess I have to reinstall imagemagick now
[10:24:43] <simon.smithies> but wonder if it could be an erlang problem
[10:24:58] <simon.smithies> which would you suggest I try first?
[10:25:09] <simon.smithies> upgrade IM or erlang?
[10:25:20] <arjan> I'd suggest IM
[10:25:33] <simon.smithies> ok :(
[10:25:51] <simon.smithies> not my favourite pastime that
[10:28:28] <arjan> you can try adding the debian-multimedia repo:
[10:28:29] <arjan> http://www.debian-multimedia.org/
[10:28:32] <arjan> they have a more recent IM
[10:28:35] <arjan> packaged
[10:29:12] <simon.smithies> that might be a bit easier
[10:29:20] <simon.smithies> thanks for the tip
[10:33:28] <arjan> np :)
[10:33:34] <arjan> I'll add it to the installation notes
[10:33:45] <simon.smithies> good idea
[11:23:44] <simon.smithies> so I've upgraded IM, but still having problems
[11:24:23] <simon.smithies> one thing I notice with the new version is the media properties dialog no longer appears with options for setting the image size
[11:25:50] <arjan> in the richtext editor?
[11:25:56] <simon.smithies> yes
[11:26:02] <arjan> it appears only if you select an image first
[11:26:18] <simon.smithies> I am doing that
[11:27:00] <simon.smithies> but the add/edit media dialog always appears regardless
[11:28:08] <simon.smithies> I can share a link to the site if you like / have time to look at it
[11:28:44] <simon.smithies> it's just a test site so can give you login credentials
[11:29:08] <arjan> what browser?
[11:29:14] <arjan> It works fine here
[11:29:17] <simon.smithies> chrome
[11:29:45] <arjan> weird
[11:29:45] <simon.smithies> and firefox
[11:29:54] <arjan> works OK here
[11:30:07] <arjan> in firefox you get resize handles around the image right?
[11:30:14] <arjan> and then click on the tree icon
[11:30:29] <simon.smithies> yes
[11:31:04] <arjan> sure, send me a link
[11:31:16] <simon.smithies> http://coolair.twigsolutions.co.nz:8000/admin/edit/313
[11:31:42] <simon.smithies> can I send the username and password some less public mechanism?
[11:33:02] <arjan> you can always mail me
[11:33:05] <arjan> arjan@miraclethings.nl
[11:35:04] <simon.smithies> ok is on its way
[11:43:41] <arjan> ah ok
[11:43:45] <arjan> it doesnt work indeed
[11:44:06] <simon.smithies> strange eh
[11:46:27] <arjan> yes
[11:47:15] <simon.smithies> I'm running in debug mode but don't see any errors logged
[11:47:35] <arjan> it has probably to do with the translation module
[11:48:21] <simon.smithies> I had to disable that to get it to work without changing my dispatch rules after an earlier upgrade
[11:48:45] <arjan> ok
[11:51:33] <arjan> can you make an issue describing the problem? https://github.com/zotonic/zotonic/issues
[11:51:43] <arjan> i'll try to fix it later today or this week
[11:51:48] <simon.smithies> ok
[11:52:55] <simon.smithies> thanks ... do you think you can repro it now? Or do you need more info?
[11:54:25] <arjan> yes I already have locally
[11:54:32] <arjan> with translation module turned off
[11:54:41] <simon.smithies> great
[11:54:55] <simon.smithies> will leave you alone now, and log that issue
[11:55:32] <simon.smithies> sorry just 1 more question
[11:55:49] <arjan> sure fire away :)
[11:56:09] <simon.smithies> can I log issues against zotonic with a public/free github login?
[11:57:24] <arjan> yes
[12:04:08] <simon.smithies> https://github.com/zotonic/zotonic/issues/286
[12:04:23] <simon.smithies> All yours :) I'm off to bed
[12:04:46] simon.smithies leaves the room
[12:23:12] Juan Jose Comellas joins the room
[12:23:19] Juan Jose Comellas leaves the room
[14:51:22] maas.maarten.zeeman joins the room
[15:04:28] maas.maarten.zeeman leaves the room
[15:22:08] juanjo joins the room
[15:22:12] juanjo leaves the room
[15:22:55] juanjo joins the room
[15:23:24] juanjo leaves the room
[15:28:55] juanjo joins the room
[15:29:00] juanjo leaves the room
[15:41:13] juanjo joins the room
[15:41:18] juanjo leaves the room
[15:52:53] maas.maarten.zeeman joins the room
[16:11:23] juanjo joins the room
[16:11:27] juanjo leaves the room
[16:41:31] juanjo joins the room
[16:41:36] juanjo leaves the room
[17:11:41] juanjo joins the room
[17:11:46] juanjo leaves the room
[17:41:49] juanjo joins the room
[17:41:55] juanjo leaves the room
[18:11:44] arjan leaves the room
[18:11:58] juanjo joins the room
[18:12:03] juanjo leaves the room
[18:34:23] maas.maarten.zeeman leaves the room
[18:42:08] juanjo joins the room
[18:42:19] juanjo leaves the room
[19:12:24] juanjo joins the room
[19:12:31] juanjo leaves the room
[19:42:37] juanjo joins the room
[19:42:41] juanjo leaves the room
[20:12:47] juanjo joins the room
[20:12:51] juanjo leaves the room
[20:22:34] arjan joins the room
[20:31:50] arjan leaves the room
[20:33:15] arjan joins the room
[20:37:45] simon.smithies joins the room
[20:42:56] juanjo joins the room
[20:43:00] juanjo leaves the room
[20:43:16] arjan leaves the room
[20:46:18] arjan joins the room
[21:13:05] juanjo joins the room
[21:13:13] juanjo leaves the room
[21:14:17] <simon.smithies> you still up?
[21:14:30] <simon.smithies> had breakfast now ... am upgrading erlang
[21:15:29] <simon.smithies> is R14B04 the best now ... or is there a later version I should move to?
[21:18:19] <arjan> yes still up :)
[21:18:29] <arjan> R14B04 is fine
[21:18:43] <simon.smithies> thanks
[21:43:18] juanjo joins the room
[21:43:22] juanjo leaves the room
[22:01:49] arjan leaves the room
[22:13:27] juanjo joins the room
[22:13:33] juanjo leaves the room
[22:29:56] simon.smithies leaves the room
[22:43:39] juanjo joins the room
[22:43:44] juanjo leaves the room
[23:04:48] arjan joins the room
[23:19:33] arjan leaves the room
[23:51:28] maas.maarten.zeeman joins the room
[23:54:49] maas.maarten.zeeman leaves the room
Powered by ejabberd Powered by Erlang Valid XHTML 1.0 Transitional Valid CSS!