Zotonic
Zotonic
zotonic@conference.zotonic.com
Wednesday, 4 January 2012< ^ >
arjan has set the subject to: Zotonic - the Erlang CMS
Room Configuration

GMT+1
[00:32:24] <Rick Cogley> Thank you for the check, Arjan.
[06:06:08] Rick Cogley leaves the room
[06:06:10] Rick Cogley joins the room
[09:28:18] arjan joins the room
[11:42:04] <Rick Cogley> Arjan - hi - please let me know if you need anything from my installation, for diagnostics. I am happy to test if / as needed.
[11:45:34] <arjan> ok
[11:46:09] arjan leaves the room
[11:47:17] arjan joins the room
[11:47:31] <arjan> so basically, you installed zotonic and everything was fine,
[11:47:43] <arjan> then you disabled some modules, and the homepage went away?
[11:49:39] <Rick Cogley> yes, I installed based on the blog skeleton, then I started exploring the modules. I was interested in importing content, so I tried enabling twitter and google blogger. Twitter gave an error right away, complaining it needed a user account (I figured there must be a place to specify, so I just disabled it for now). After I enabled the blogger import, after a while I saw the buttons for it appear in the admin interface.
[11:50:36] <arjan> ok
[11:50:44] <arjan> so you did not deactivate any module?
[11:51:31] <Rick Cogley> yes, I deactivated twitter, and, I also had activated survey, added a page and tested it (seemed to work ok), then I noticed the home page was gone, so I deactivated survey.
[11:51:56] <Rick Cogley> Also - I activated the csv import and could not find what to do with it, so I deactivated it too.
[11:52:27] <Rick Cogley> I figured, there must be a readme somewhere for these, so I will learn about them slowly and enable as I learn them. At first I was kind of just enabling whatever seemed interesting.
[11:53:48] <Rick Cogley> brb
[11:55:56] <arjan> do you have a home.tpl file?
[11:56:11] <arjan> in your site's templates/ folder
[11:57:33] <arjan> did you delete any articles?
[11:57:44] <arjan> also try the following:
[11:57:50] <arjan> go into admin -> system
[11:57:58] <arjan> click the "renumber category tree" button
[11:58:05] <arjan> then wait a little
[11:59:14] <arjan> the homepage is empty because it can't find any articles, it seems
[12:00:11] <arjan> hey that seems to have helped
[12:10:45] <Rick Cogley> Hi - just got back. Before I left, I noticed that the articles had re-appeared for some reason. I have no idea when they did that.
[12:12:04] <Rick Cogley> when I look at the page in either safari or chrome, both latest, on OS X, I get broken images now. They were working before.
[12:13:53] <Rick Cogley> [rcogley@web307 templates]$ ls -la
total 80
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 06:20 .
drwxrwxr-x 9 rcogley rcogley 4096 Jan 3 12:02 ..
-rw-rw-r-- 1 rcogley rcogley 617 Jan 3 06:20 archives.tpl
-rw-rw-r-- 1 rcogley rcogley 261 Jan 3 06:20 _article_chapeau.tpl
-rw-rw-r-- 1 rcogley rcogley 285 Jan 3 06:20 _article_keywords.tpl
-rw-rw-r-- 1 rcogley rcogley 168 Jan 3 06:20 _article_meta.tpl
-rw-rw-r-- 1 rcogley rcogley 541 Jan 3 06:20 _article_prevnext.tpl
-rw-rw-r-- 1 rcogley rcogley 462 Jan 3 06:20 _article_sidebar.tpl
-rw-rw-r-- 1 rcogley rcogley 1241 Jan 3 06:20 _article_summary.tpl
-rw-rw-r-- 1 rcogley rcogley 568 Jan 3 06:20 article.tpl
-rw-rw-r-- 1 rcogley rcogley 2564 Jan 3 06:20 base.tpl
-rw-rw-r-- 1 rcogley rcogley 713 Jan 3 06:20 _body_media.tpl
-rw-rw-r-- 1 rcogley rcogley 625 Jan 3 06:20 by_keyword.tpl
-rw-rw-r-- 1 rcogley rcogley 769 Jan 3 06:20 contact.tpl
-rw-rw-r-- 1 rcogley rcogley 421 Jan 3 06:20 _email_contact.tpl
-rw-rw-r-- 1 rcogley rcogley 931 Jan 3 06:20 home.tpl
-rw-rw-r-- 1 rcogley rcogley 131 Jan 3 06:20 _listitem.tpl
-rw-rw-r-- 1 rcogley rcogley 357 Jan 3 06:20 page.query.tpl
-rw-rw-r-- 1 rcogley rcogley 841 Jan 3 06:20 page.tpl
-rw-rw-r-- 1 rcogley rcogley 1732 Jan 3 06:20 _sidebar.tpl
[12:14:14] <Rick Cogley> that is the ls from my templates folder
[12:14:18] <Rick Cogley> I do have home.tpl
[12:14:40] <Rick Cogley> no, I did not delete any articles, to answer your question.
[12:15:03] <Rick Cogley> I did not know what "renumber category tree" did, so I did not click it yet. I will click it now.
[12:16:55] <Rick Cogley> ok, I clicked "renumber category tree". In a new site like this, how long should that take? And, what does it do? Is it like reindexing?
[12:17:54] <Rick Cogley> the only editing I did, by the way, was to add a table to this page: http://rick3.cogley.info/en/article/317/welcome-to-zotonic
[12:20:11] <Rick Cogley> The images that are not showing, are listed in the admin side as being protected from deletion. Is there any common problem that can cause them to disappear?
[12:22:10] <Rick Cogley> Is this where images are stored? /home/rcogley/opt/zotonic/priv/sites/rick_cogley_info/files/preview/lib/images
[12:22:17] <Rick Cogley> or, are they stored as BLOBs in the db?
[12:22:26] <arjan> no they are stored on disk
[12:22:39] <arjan> in /home/rcogley/opt/zotonic/priv/sites/rick_cogley_info/files/archive
[12:22:59] <arjan> after resize, they are kept in files/preview/*
[12:25:50] <Rick Cogley> there is no archive folder
[12:26:01] <Rick Cogley> these are just the images that were included in the base install
[12:26:09] <Rick Cogley> where did they go...
[12:26:19] <Rick Cogley> I was not even in that folder at all, until just now...
[12:26:55] <arjan> lets see
[12:26:58] <Rick Cogley> the only thing in files/preview now is,
[12:26:59] <Rick Cogley> [rcogley@web307 images]$ pwd
/home/rcogley/opt/zotonic/priv/sites/rick_cogley_info/files/preview/lib/images
[rcogley@web307 images]$ ls -la
total 12
drwxrwxr-x 2 rcogley rcogley 4096 Jan 4 12:15 .
drwxrwxr-x 3 rcogley rcogley 4096 Jan 4 12:15 ..
-rw-rw-r-- 1 rcogley rcogley 1439 Jan 4 12:15 vimeo.jpg(40x18)(crop)(2017E71C926C0E50440EB351E38342AA).jpg
[12:28:13] <arjan> no archive folder at all?
[12:28:17] <Rick Cogley> none
[12:28:25] <arjan> thats weird
[12:28:48] <arjan> if you upload a new image?
[12:29:02] <Rick Cogley> ok, I will try
[12:29:10] <Rick Cogley> here is /files/
[12:29:11] <Rick Cogley> [rcogley@web307 files]$ pwd
/home/rcogley/opt/zotonic/priv/sites/rick_cogley_info/files
[rcogley@web307 files]$ ls -la
total 28
drwxrwxr-x 7 rcogley rcogley 4096 Jan 3 13:56 .
drwxrwxr-x 9 rcogley rcogley 4096 Jan 3 12:02 ..
drwxrwxr-x 2 rcogley rcogley 4096 Jan 4 03:56 backup
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 dropbox
drwxrwxr-x 3 rcogley rcogley 4096 Jan 4 12:15 preview
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 processing
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 unhandled
[12:33:40] <Rick Cogley> ok, I uploaded a new media item and linked it here: http://rick3.cogley.info/en/article/317/welcome-to-zotonic
[12:34:34] <arjan> cool, so it works
[12:34:45] <arjan> only the images form the default install did not
[12:34:56] <arjan> thats strange because I just installed a new site as well and those work
[12:34:59] <arjan> what OS are you on?
[12:35:17] <Rick Cogley> now the archive folder is here
[12:35:21] <Rick Cogley> [rcogley@web307 files]$ ls -la
total 32
drwxrwxr-x 8 rcogley rcogley 4096 Jan 4 12:30 .
drwxrwxr-x 9 rcogley rcogley 4096 Jan 3 12:02 ..
drwxrwxr-x 3 rcogley rcogley 4096 Jan 4 12:30 archive
drwxrwxr-x 2 rcogley rcogley 4096 Jan 4 03:56 backup
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 dropbox
drwxrwxr-x 4 rcogley rcogley 4096 Jan 4 12:30 preview
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 processing
drwxrwxr-x 2 rcogley rcogley 4096 Jan 3 11:59 unhandled
[12:35:41] <Rick Cogley> the photos indeed worked, when I first installed. Something messed with that archive folder
[12:36:11] <Rick Cogley> The server is centos 6 - latest from webfaction. My laptop is OS X 10.7.
[12:37:15] <Rick Cogley> [rcogley@web307 4]$ pwd
/home/rcogley/opt/zotonic/priv/sites/rick_cogley_info/files/archive/2012/1/4
[rcogley@web307 4]$ ls -la
total 16
drwxrwxr-x 2 rcogley rcogley 4096 Jan 4 12:30 .
drwxrwxr-x 3 rcogley rcogley 4096 Jan 4 12:30 ..
-rw-rw-r-- 1 rcogley rcogley 7029 Jan 4 12:30 rick_cogley_craig_jenkins_photo_1_web.jpg
[12:42:20] <Rick Cogley> uploaded a larger version and it attaches fine too
[12:42:22] <Rick Cogley> http://rick3.cogley.info/en/page/314/about-this-blog
[12:42:43] <Rick Cogley> [rcogley@web307 4]$ ls -la
total 1088
drwxrwxr-x 2 rcogley rcogley 4096 Jan 4 12:39 .
drwxrwxr-x 3 rcogley rcogley 4096 Jan 4 12:30 ..
-rw-rw-r-- 1 rcogley rcogley 1089588 Jan 4 12:39 rick_cogley_craig_jenkins_photo_1.jpg
-rw-rw-r-- 1 rcogley rcogley 7029 Jan 4 12:30 rick_cogley_craig_jenkins_photo_1_web.jpg
[12:43:25] <Rick Cogley> be back in 15
[12:46:28] arjan leaves the room
[12:47:07] arjan joins the room
[12:57:54] arjan leaves the room
[12:58:27] arjan joins the room
[13:11:02] <Rick Cogley> wow, nice, I can easily embed photos from my smugmug site
[13:11:03] <Rick Cogley> http://rick3.cogley.info/en/article/318/want-to-learn-more
[13:11:12] <Rick Cogley> seamless and nice.
[13:12:53] <Rick Cogley> ah, ok, it copies the photo to the archive folder.
[13:20:23] <arjan> yes
[13:20:31] <arjan> nice that it works now :)
[14:27:17] <Rick Cogley> indeed. Is there a way to embed regular image media from another site, instead of importing it into the archive folder? When I embed an image, it ends up as a video and when it is displayed, it is displayed large. Another related question, is there a way to size the image when you link to it within a content page?
[14:40:08] <arjan> what do you mean by "other media"?
[14:40:23] <arjan> the images are always imported
[14:40:39] <arjan> there is an OEmbed module which is maybe a help
[14:40:47] <arjan> it allows you to link to other media on other sites
[14:40:55] <arjan> not only images but video, audio, etc
[14:41:08] <arjan> the image is not imported (well, only a thumbnail)
[14:43:50] <Rick Cogley> i have OEmbed enabled.
[14:44:29] <Rick Cogley> Is the manifestation in the media section the tab that says, "embed url" ?
[14:46:40] <Rick Cogley> when I use that, it works, but, the system thinks my image url is a video. I know it is not hosted locally because I can click through to the image, outside, on my smugmug site.
[14:47:14] <Rick Cogley> however, in the media list, it is listed as a video, and has the > button on a white background where the image thumb should be.
[14:48:59] <Rick Cogley> i see I can change the media category from video to image, but, even though I did this (changed to image) it still lists the image as a video.
[14:49:57] <arjan> (02:44:29 PM) Rick Cogley: Is the manifestation in the media section the tab that says, "embed url" ? --> yes
[14:50:15] <Rick Cogley> ok
[14:50:16] <arjan> can you give a smugmug url?
[14:50:21] <Rick Cogley> sure
[14:50:37] <Rick Cogley> http://rickcogley.smugmug.com/Family/Cogley-Summer-Vacation-in/20864276_gg3LkQ#1656446712_SR7qsML-A-LB
[14:51:13] <Rick Cogley> http://rickcogley.smugmug.com/Family/Cogley-Summer-Vacation-in/i-SR7qsML/0/X3/Cogley-Summer-Vacation-Shimoda-X3.jpg
[14:52:20] <arjan> I dont think oembed module supports smugmug
[14:52:55] <arjan> it says "invalid media url" here
[14:53:40] <Rick Cogley> if I use the jpeg URL, it works. But it thinks it is a video…
[14:53:51] <Rick Cogley> FYI this is the gallery of images - http://rickcogley.smugmug.com/Family/Cogley-Summer-Vacation-in/20864276_gg3LkQ
[14:54:24] <Rick Cogley> For example this is what it looks like -
[14:54:25] <Rick Cogley> http://rick3.cogley.info/en/page/341/shimoda-embed
[14:55:11] <Rick Cogley> it seems to treat the URL differently and just maxes the size out.
[14:56:01] <Rick Cogley> i attached it to the bottom of this page too
[14:56:02] <Rick Cogley> http://rick3.cogley.info/en/article/319/zotonic-s-typography
[14:56:43] <Rick Cogley> in zotonic is there no way to resize these on the fly?
[14:58:37] <arjan> yes ofcourse there is
[14:59:09] <arjan> if you dont use "Embed Url" tab, but the "Url" tab instead when you create a picture
[14:59:33] <arjan> you get a normal picture item instead of an embedded one (which apparently does not work well for smugmug)
[14:59:46] <Rick Cogley> ok
[14:59:46] <arjan> normal pictures can be resized without problems
[14:59:49] <Rick Cogley> I did that too
[14:59:59] <Rick Cogley> um, how do I resize them?
[15:00:17] <Rick Cogley> I am viewing the site with safari, does that effect the functionality perhaps?
[15:00:58] <Rick Cogley> in the editor, when I place an image that I uploaded to the site (i.e. not an embed) I only get a selection box around the whole image. I do not get any "resizing handles".
[15:10:29] <arjan> well in the editor there is no resize option really
[15:10:34] <arjan> you can choose between 3 sizes
[15:10:41] <arjan> select the image and click the embed icon again
[15:10:44] <arjan> pops up a dialog box
[15:12:00] <Rick Cogley> ah!
[15:12:35] <Rick Cogley> that works
[15:12:35] <Rick Cogley> http://rick3.cogley.info/en/article/319/zotonic-s-typography
[15:12:46] <arjan> :)
[15:13:27] <Rick Cogley> I tried it in firefox as well, and, you do get resize handles in firefox, but, they do not seem to have any effect. Safari and Chrome, no, you do not get handles. The trick of selecting then re-clicking the button on the button bar, works in safari and chrome.
[15:14:38] <arjan> yes
[15:14:39] <arjan> resizing is not supposed to work in the editor anyway
[15:16:05] <Rick Cogley> it is just wishful thinking on my part. The solution you have thought up is elegant and works.
[15:30:19] <Rick Cogley> I see that on a page I can associate "page connections". Where do things like Relations, About, Documents come into play? Where do I see those, in the user interface? I can see keywords for instance, but not relations…
[15:30:45] <Rick Cogley> Appreciate your help Arjan. Getting late again. I will sleep some now, and experiment more tomorrow.
[19:50:16] maas.maarten.zeeman joins the room
[20:33:41] arjan leaves the room
[22:27:56] <Rick Cogley> good morning - maas, I see you are in the room - if you are online, can you tell me the idea behind the page connections. In the admin interface, I see Relations, About, Documents, Keywords. In the "front end" I see only keywords, among those. (I am just testing the blog skeleton without modification). Are these things you see and use in the front end?
[22:33:43] arjan joins the room
[22:38:02] <arjan> page connections relate different pages to eachother
[22:38:10] <arjan> you can use them for many things
[22:38:30] <arjan> for instance, an article written by somebody is an "author" connection from the article to the person
[22:38:53] <arjan> images connected to an article are also a kind of page connections
[22:39:02] <arjan> treated the same way but displayed differently
[22:40:06] <Rick Cogley> ok, I get that much. This page shows links for author, a linked image, keywords - http://rick3.cogley.info/en/article/317/welcome-to-zotonic
[22:40:34] <Rick Cogley> If I wanted to relate pages, and show the relations, would I edit the template?
[22:41:48] <arjan> That depends
[22:41:51] <arjan> but in most cases, yes
[22:42:07] <arjan> We almost always create custom templates
[22:49:15] arjan leaves the room
[22:58:46] <Rick Cogley> ok - I am looking at the template contents and I see how you are variously adding / including the content from the backend, in the front end.
[22:58:50] <Rick Cogley> Interesting,
[22:58:51] <Rick Cogley> .
[23:40:21] <Rick Cogley> Trying to set up the twitter module. Got the key/value pairs added I think. FYI, the RSS feed is no longer available to get the numeric ID from, but I found this site: http://www.idfromuser.com/
[23:42:22] <Rick Cogley> when I enter the key-value pairs in admin/config, should the name of the module be twitter, or, mod_twitter
[23:43:08] <Rick Cogley> also - should the feed simply "show up" somewhere, in the blog skeleton?
Powered by ejabberd Powered by Erlang Valid XHTML 1.0 Transitional Valid CSS!